LivePOS.com Hosting Upgrade
Incident Report for LivePOS
Resolved
The LivePOS.com upgrade has been completed.
Posted Mar 21, 2016 - 09:38 PDT
Identified
The LivePOS.com site is currently down for maintenance. Please note that his has NO EFFECT on your Dashboard or your POS systems. to access your Dashboard please visit http://admin.cssholdings.com

Once the upgrade is completed LivePOS.com will come back online with its newly redesigned layout. We hope you like it :-)

LivePOS Team
Posted Mar 14, 2016 - 17:38 PDT