Phone system issue, long wait time
Incident Report for LivePOS
Resolved
This incident has been resolved.
Posted Apr 17, 2019 - 11:01 PDT
Monitoring
It looks like the issue has been resolved, we are monitoring the situation.
Posted Apr 16, 2019 - 17:37 PDT
Investigating
Our phone system provider reported an issue with inbound calls. It is possible that you will encounter long wait times until this issue is resolved. If the issue is not urgent, we ask that you call back later to avoid long wait times. We thank you for your patience while we continue to investigate this issue with our hosted phone system provider.
Posted Apr 16, 2019 - 17:26 PDT
This incident affected: Support Call Center ?.